Jenkins Job runs in 2 executors at a time

  • I have a jenkins master and slave setup
  • When a branch is created and developer push code to a branch (eg: test_branch)
  • When job starts jenkins will show the build running in 2 executors with same build
  • we are not using concurrent builds plugin

My question is how to disable it so that 1 build will run in 1 executor only.