[Solved] wrong fs type, bad option, bad superblock on /dev/sdb Error

When you try to mount a formatted disk to a different server, you might get the following error.

mount: wrong fs type, bad option, bad superblock on /dev/sdb,
   missing codepage or helper program, or other error

There could be many reasons for this error. What i found is , normally if you try to mount a partitioned disk, this error would appear.

First check if the disk is partitioned using the following command.

[email protected]:$ lsblk
sda      8:0    0   10G  0 disk 
└─sda1   8:1    0   10G  0 part /
sdb      8:16   0    1T  0 disk 
└─sdb1   8:17   0 1024G  0 

In the example you can see that sdb is partitioned to sdb1. So instead of mounting the device /dev/sdb mount /dev/sdb1 partition. An example mount command is shown below.

sudo mount /dev/sdb1 /mount/path

Don’t know if you can see this reply after 4y , after spending more than 2h on *** mounting a dok i found yours so simple solution ! partitionnnnssss ! ,


This worked! Surprisingly not many answers out there suggest similar. Thanks!